DNS関連技術情報のトップへ戻る

---------------------------------------------------------------------
■(緊急)BIND 9.xの脆弱性(DNSサービスの停止)について(CVE-2016-9147)
  - DNSSEC検証を実施していない場合も対象、バージョンアップを強く推奨 -

                                株式会社日本レジストリサービス(JPRS)
                                            初版作成 2017/01/12(Thu)
---------------------------------------------------------------------

▼概要

  BIND 9.xにおける実装上の不具合により、namedに対する外部からのサービ
  ス不能(DoS)攻撃が可能となる脆弱性が、開発元のISCから発表されました。
  本脆弱性により、提供者が意図しないサービスの停止が発生する可能性があ
  ります。

  本脆弱性は、フルリゾルバー(キャッシュDNSサーバー)の機能が有効に設
  定されているBIND 9.9.9-P4、9.10.4-P4、9.11.0-P1が影響を受けます。該
  当するBIND 9.xを利用しているユーザーは関連情報の収集やバージョンアッ
  プなど、適切な対応を速やかに取ることを強く推奨します。

▼詳細

▽本脆弱性の概要

  BIND 9.xにはDNSSEC関連のRRSetの処理に不具合があり、矛盾するDNSSEC関
  連のRRSetを含む応答を受け取った際の内部処理において、namedが異常終了
  を起こす障害が発生します(*1)。

  (*1)本脆弱性によりnamedが異常終了した場合、assertion failureを引き
        起こした旨のメッセージがログに出力されます。

  本脆弱性により、DNSサービスの停止が発生する可能性があります。また、
  本脆弱性を利用した攻撃はリモートから可能です。

▽対象となるバージョン

  本脆弱性は、BIND 9.9.9-P4、9.10.4-P4、9.11.0-P1が該当します。

  ・9.11系列:9.11.0-P1
  ・9.10系列:9.10.4-P4
  ・9.9系列:9.9.9-P4

▽影響範囲

  ISCは、本脆弱性の深刻度(Severity)を「高(High)」と評価しています。

  ISCでは、本脆弱性のリスクはフルリゾルバーにおいて高く、権威DNSサーバー
  ではDNS NOTIFYにおいて当該ゾーンのNSレコードに記述された権威DNSサー
  バーのIPアドレスを検索している場合など、限定的であると発表しています
  (*2)。

  (*2)BIND 9では設定ファイル(named.conf)でnotify no;またはnotify
        explicit;を指定していない場合、DNS NOTIFYを利用したゾーン転送
        の際にNSレコードに記述された権威DNSサーバー名に対する名前解決
        が、必要に応じて実行されます。

  本脆弱性は、DNSSEC検証に関する処理の脆弱性です。しかし、ISCではサー
  バー側でDNSSEC検証を実施していない場合にも本脆弱性の対象となり、かつ
  サーバー側でDNSSEC検証を無効にすることは本脆弱性の回避手段とはならな
  いと発表しています。

  本脆弱性については、以下の脆弱性情報(*3)も併せてご参照ください。

  (*3)CVE - CVE-2016-9147
        <https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9147>

▼一時的な回避策

  本脆弱性の一時的な回避策は存在しません。

▼解決策

  本脆弱性を修正したパッチバージョン(BIND 9.11.0-P2/9.10.4-P5/
  9.9.9-P5)への更新、あるいは各ディストリビューションベンダーからリリー
  スされる更新の適用を、速やかに実施してください。

▼参考リンク

  以下に、ISCから発表されている情報へのリンクを記載します。また、各ディ
  ストリビューションベンダーからの情報や前述のCVEの情報なども確認の上、
  適切な対応を取ることを強く推奨します。

  - ISC

   セキュリティアドバイザリ

    CVE-2016-9147: An error handling a query response containing
                   inconsistent DNSSEC information could cause an
                   assertion failure
    <https://kb.isc.org/article/AA-01440>

   パッチバージョンの入手先

    BIND 9.11.0-P2
    <https://ftp.isc.org/isc/bind9/9.11.0-P2/bind-9.11.0-P2.tar.gz>
    BIND 9.10.4-P5
    <https://ftp.isc.org/isc/bind9/9.10.4-P5/bind-9.10.4-P5.tar.gz>
    BIND 9.9.9-P5
    <https://ftp.isc.org/isc/bind9/9.9.9-P5/bind-9.9.9-P5.tar.gz>

▼連絡先

  本文書に関するお問い合わせは <dnstech-info@jprs.jp> までご連絡ください。

---------------------------------------------------------------------
▼更新履歴
  2017/01/12 11:00 初版作成


株式会社日本レジストリサービス Copyright©2001-2017 Japan Registry Services Co., Ltd.